Cheat Engine Forum Index Cheat Engine
The Official Site of Cheat Engine
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


Forward slash turns into #, and cash sign turns into SOLVED
Goto page Previous  1, 2
 
Post new topic   This topic is locked: you cannot edit posts or make replies.    Cheat Engine Forum Index -> Computer Talk
View previous topic :: View next topic  
Author Message
Shiaoran
Newbie cheater
Reputation: 0

Joined: 29 Oct 2006
Posts: 22

PostPosted: Wed Aug 12, 2009 5:19 pm    Post subject: Reply with quote

Try creating a custom layout.
It could fix your problems and give you the option to set useful stuff to keys and in a way you like them.
Back to top
View user's profile Send private message
Luigi
Grandmaster Cheater Supreme
Reputation: 0

Joined: 24 Mar 2008
Posts: 1025

PostPosted: Wed Aug 12, 2009 5:20 pm    Post subject: Reply with quote

Shiaoran wrote:
Try creating a custom layout.
It could fix your problems and give you the option to set useful stuff to keys and in a way you like them.
Tried it. I don't think the microsoft one let's you change all the keys.
Back to top
View user's profile Send private message
Shiaoran
Newbie cheater
Reputation: 0

Joined: 29 Oct 2006
Posts: 22

PostPosted: Wed Aug 12, 2009 5:24 pm    Post subject: Reply with quote

Yes it does...
I use Microsoft Keyboard Layout Creator 1.4 and it works perfectly. I have lots of characters easily acessible on keys made for other characters.

For example, /? contains /?\|, while \| contains other characters I use but aren't found on a default layout.
Back to top
View user's profile Send private message
Luigi
Grandmaster Cheater Supreme
Reputation: 0

Joined: 24 Mar 2008
Posts: 1025

PostPosted: Wed Aug 12, 2009 6:38 pm    Post subject: Reply with quote

Shiaoran wrote:
Yes it does...
I use Microsoft Keyboard Layout Creator 1.4 and it works perfectly. I have lots of characters easily acessible on keys made for other characters.

For example, /? contains /?\|, while \| contains other characters I use but aren't found on a default layout.
Did it, and tested it with the project test thing. It worked beautifully, but when I installed, it does not work. Is there somewhere I need to apply it at?
Back to top
View user's profile Send private message
kls85
I post too much
Reputation: 22

Joined: 18 Jul 2008
Posts: 2757
Location: Under ur bed

PostPosted: Wed Aug 12, 2009 9:57 pm    Post subject: Reply with quote

Looks like from the attached pic you have a regular XP not the UK version.
XP -N= UK version.

I've managed to create the exact issue your having under a VM, where # becomes the sign and so forth.

Follow these steps and see if you can get your keys back in working order.

1. Go to Device Manager and verify that your keyboard is label as
Standard 101/102-Key or Microsoft Natural PS/2 Keyboard

2. If that is correct, head over to control panel and open up Regional and Language Options.
If keyboard is not exactly as above, go to update drivers, and manually force install it.

3. Inside Regional and Language options at the top, click on the Languages tab and click details.

4. In here you should see the type of keyboard your currently using.

5. Click on Add and under Input Language, select English (United States)
Under Keyboard layout/IME, select US
Not United States-Dvorak or other US w/extension layouts, just plain US.

6. Now click apply and OK and do the same for the other windows until you close off regional and language options.

7. If you have done it right, there should be a small "EN" somewhere on the task bar. Click on it and there should be US keyboard layout.

8. Fire up wordpad, notepad or whatever you have and select the US keyboard layout and type in the characters to see if they work or not.

9. If yes, then go back to regional and language options and to the place where you add the keyboard.

10. In that area under "Default input language" select English (United States) - US. Notice US keyboard is now bold.
Click on Apply (do not click on OK yet)

11. Select UK keyboard and click remove, click apply and OK.
Click apply and Ok one more time and close off all windows that was opened.

12. Open up wordpad and try to see if your keys are back the way they should be.

Back to top
View user's profile Send private message
Shiaoran
Newbie cheater
Reputation: 0

Joined: 29 Oct 2006
Posts: 22

PostPosted: Thu Aug 13, 2009 4:28 am    Post subject: Reply with quote

Luigi wrote:
Shiaoran wrote:
Yes it does...
I use Microsoft Keyboard Layout Creator 1.4 and it works perfectly. I have lots of characters easily acessible on keys made for other characters.

For example, /? contains /?\|, while \| contains other characters I use but aren't found on a default layout.
Did it, and tested it with the project test thing. It worked beautifully, but when I installed, it does not work. Is there somewhere I need to apply it at?


You have to add it in the regional and language options. You can remove other layouts for the same region/language, as they are probably useless now.
Back to top
View user's profile Send private message
Luigi
Grandmaster Cheater Supreme
Reputation: 0

Joined: 24 Mar 2008
Posts: 1025

PostPosted: Thu Aug 13, 2009 1:22 pm    Post subject: Reply with quote

kls85 wrote:
Looks like from the attached pic you have a regular XP not the UK version.
XP -N= UK version.

I've managed to create the exact issue your having under a VM, where # becomes the sign and so forth.

Follow these steps and see if you can get your keys back in working order.

1. Go to Device Manager and verify that your keyboard is label as
Standard 101/102-Key or Microsoft Natural PS/2 Keyboard

2. If that is correct, head over to control panel and open up Regional and Language Options.
If keyboard is not exactly as above, go to update drivers, and manually force install it.

3. Inside Regional and Language options at the top, click on the Languages tab and click details.

4. In here you should see the type of keyboard your currently using.

5. Click on Add and under Input Language, select English (United States)
Under Keyboard layout/IME, select US
Not United States-Dvorak or other US w/extension layouts, just plain US.

6. Now click apply and OK and do the same for the other windows until you close off regional and language options.

7. If you have done it right, there should be a small "EN" somewhere on the task bar. Click on it and there should be US keyboard layout.

8. Fire up wordpad, notepad or whatever you have and select the US keyboard layout and type in the characters to see if they work or not.

9. If yes, then go back to regional and language options and to the place where you add the keyboard.

10. In that area under "Default input language" select English (United States) - US. Notice US keyboard is now bold.
Click on Apply (do not click on OK yet)

11. Select UK keyboard and click remove, click apply and OK.
Click apply and Ok one more time and close off all windows that was opened.

12. Open up wordpad and try to see if your keys are back the way they should be.

Stuck at 5. There is NOTHING else besides Dvorak. Might be because after I reformatted, the language bar was already there and set to UK, but US is there, and every time I click it, it doesn't set to it.

EDIT: I fixed it just by removing the UK layout. !@#$%^&*()"\
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   This topic is locked: you cannot edit posts or make replies.    Cheat Engine Forum Index -> Computer Talk All times are GMT - 6 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum



Powered by phpBB © 2001, 2005 phpBB Group

CE Wiki   IRC (#CEF)